QHYCCD

Polemaster software on POP_os 20.04 (ubuntu) not working.

Polemaster software on POP_os 20.04 (ubuntu) not working.
« on: March 19, 2021, 11:01:03 AM »
Hello All,
I'd like to request help getting my pole master install working.
I installed the stable version from the downloads page, had no errors on install but the software failed to start when clicking the desktop icon.

I did find this post: https://www.qhyccd.com/bbs/index.php?topic=6782.0
Found I was missing the same libs and the correction steps did restore those libs for me.

Code: [Select]
stephaniefuda@pop-os:/usr/bin/PoleMaster$ ldd PoleMaster
linux-vdso.so.1 (0x00007ffd37534000)
libqhy.so.1 => /lib/x86_64-linux-gnu/libqhy.so.1 (0x00007f4370057000)
libopencv_imgproc.so.2.4 => /lib/x86_64-linux-gnu/libopencv_imgproc.so.2.4 (0x00007f436fb53000)
libopencv_core.so.2.4 => /lib/x86_64-linux-gnu/libopencv_core.so.2.4 (0x00007f436f6b6000)
libQt5Widgets.so.5 => /lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f436f01b000)
libQt5Gui.so.5 => /lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f436ea30000)
libQt5Core.so.5 => /lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f436e4e7000)
libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f436e304000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f436e1b5000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f436e19a000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f436dfa8000)
libusb-1.0.so.0 => /lib/x86_64-linux-gnu/libusb-1.0.so.0 (0x00007f436df8c000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f436df70000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f436df4b000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f436df40000)
libGL.so.1 => /lib/x86_64-linux-gnu/libGL.so.1 (0x00007f436deb8000)
libpng16.so.16 => /lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f436de80000)
libharfbuzz.so.0 => /lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f436dd7b000)
libicui18n.so.66 => /lib/x86_64-linux-gnu/libicui18n.so.66 (0x00007f436da7a000)
libicuuc.so.66 => /lib/x86_64-linux-gnu/libicuuc.so.66 (0x00007f436d894000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f436d88e000)
libpcre2-16.so.0 => /lib/x86_64-linux-gnu/libpcre2-16.so.0 (0x00007f436d80b000)
libdouble-conversion.so.3 => /lib/x86_64-linux-gnu/libdouble-conversion.so.3 (0x00007f436d7f5000)
libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f436d6cc000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4379289000)
libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007f436d69d000)
libGLdispatch.so.0 => /lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f436d5e5000)
libGLX.so.0 => /lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f436d5b1000)
libfreetype.so.6 => /lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f436d4f2000)
libgraphite2.so.3 => /lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f436d4c5000)
libicudata.so.66 => /lib/x86_64-linux-gnu/libicudata.so.66 (0x00007f436ba02000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f436b98f000)
libX11.so.6 => /lib/x86_64-linux-gnu/libX11.so.6 (0x00007f436b852000)
libxcb.so.1 => /lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f436b828000)
libXau.so.6 => /lib/x86_64-linux-gnu/libXau.so.6 (0x00007f436b822000)
libXdmcp.so.6 => /lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f436b818000)
libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f436b7fe000)

My os info:
Code: [Select]
stephaniefuda@pop-os:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Pop
Description: Pop!_OS 20.04 LTS
Release: 20.04
Codename: focal

I can run `sudo /usr/bin/PoleMaster/PoleMaster` and the application will open but at no time does it recognize the camera.

I've tried different USB ports, rebooting with the camera plugged in and without it plugged in with no change. the camera is just not recognized.

I'd like to solve two issues:
  • I'd like to get the desktop icon working (changing the path in the desktop icon failed for me)
  • I'd like the software to recognize the camera

I'm new to Ubuntu and would appreciate any help or suggestions anyone can offer.
Thanks!
Stephanie
« Last Edit: March 20, 2021, 12:00:31 PM by StephanieFuda »

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #1 on: March 21, 2021, 08:11:47 PM »
Hi,
    Maybe you can try this version software:www.qhyccd.com/file/repository/latestSoftAndDirver/Soft/PoleMaster_QtforLinux64LatestEdition.zip
Best Regards,
QinXiaoXu

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #2 on: March 29, 2021, 05:47:28 PM »
Hello QinXiaoXu,
Thank you for this I did just upgrade with the link you provided but I'm having the same issues.

I've attached a couple of screenshots, of the "old PoleMaster" command, showing missing libraries.
When I tried to re-add the libs I got a message about a missing directory.

Before I try to restore those folders and libs I wanted to show you this in case you had additional feedback.
Please let me know what you recommend.

Thanks,
Stephanie

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #3 on: March 29, 2021, 08:17:14 PM »
Hi,
    The libqhy library is old,now our SDK name is libqhyccd.And the new version is contain the new SDK,so I recommand new version.
Best Regards,
QinXiaoXu

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #4 on: March 30, 2021, 06:47:28 PM »
Hi QinXiaoXu,
I updated my software from the link you provided in your last reply. Do I need to do something else?
Do I need to download anything else?

Thanks again,
Stephanie

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #5 on: March 30, 2021, 07:57:24 PM »
Hello again QinXiaoXu,
I updated my SDK from the 20.03.13 release, then uninstalled/reinstalled the software from the link you provided and this is the new result of running ldd Polemaster in the attached screenshot.
Can you let me know what I should do next?

Thank you again for your help!
Stephanie

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #6 on: March 30, 2021, 08:24:25 PM »
Hi,
    Did you install the Linux driver?If not,you need install it,https://www.qhyccd.com/file/repository/publish/SDK/210313/sdk_linux64_21.03.13.tgz
Best Regards,
QinXiaoXu

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #7 on: April 03, 2021, 09:11:52 AM »
Thank you yes, I did.
The last screenshot I sent was after doing a full removal and reinstallation of the Linux SDK.

Thank you again,
Stephanie

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #8 on: April 05, 2021, 09:07:06 PM »
Hi,
    It shown that your system have no some opencv libraries,you can untar this to /usr/lib/x86_64,if it still can't help you,we can do remote control for it.
Best Regards,
QinXiaoXu

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #9 on: April 15, 2021, 06:46:15 PM »
Hello QinXiaoXu,
Sorry for my slow reply.

The libs you sent were a great help, I did also have to run
Code: [Select]
sudo apt-get install libtbb-dev to get my final missing libs but Polemaster is working now :D

The only thing I can't figure out is the desktop icon, I still have to use
Code: [Select]
sudo /usr/bin/PoleMaster/PoleMaster
to launch the app, but I'm happy the app is working now.

Thank you for the help!
stephanie

Re: Polemaster software on POP_os 20.04 (ubuntu) not working.
« Reply #10 on: April 15, 2021, 08:11:22 PM »
Hi,
    I'm working on desktop icon issue,now the issue is root issue,after I solve it,I will send you the file.
Best Regards,
QinXiaoXu