QHYCCD

Qh8L 64Bit ASCOM drivers not working

Sniuk

Qh8L 64Bit ASCOM drivers not working
« on: January 31, 2021, 10:08:01 AM »
Been using NiNa for a while, but couldn't change the settins of the camera (such as download speed, CLAMP and so on...) apparently NiNa selects fast  speed download automatically without being able to change it... while, hopefully, waiting they will fix  this, I can not use ASCOM drivers on NiNa 64bit version. It appears that the driver is registered/installed as 32bit, and thus it doesn't recognize it.

I checked ASCOM diagnostics, and found same problem when running it in 64bit.  I downloaded the lastest drivers I've found, both specific to qhy8.L and the "all in one" version. and still not working.

I attach two pictures of the forementioned problem.

How can I fix this? Is this a problem with SDK 64bit driver ? I can not find any version that works and doesn't give me this error.

Thank you

Carles.

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #1 on: January 31, 2021, 07:58:57 PM »
Hi,
    Did you try the ASCOM plug-in driver in this installer?https://www.qhyccd.com/file/repository/publish/AllInOne/210106/QHYCCD_Win_AllInOne.21.01.06.13.exe
Best Regards,
QinXiaoXu

Sniuk

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #2 on: February 01, 2021, 04:15:11 AM »
Hi,
    Did you try the ASCOM plug-in driver in this installer?https://www.qhyccd.com/file/repository/publish/AllInOne/210106/QHYCCD_Win_AllInOne.21.01.06.13.exe
Best Regards,
QinXiaoXu

Dear QinXiaoXu,

I didn't try it since my camera wasn't listed in the all in one package, nevertheless I've downloaded it and tried, but doesn't work in NiNa either.
Then I ran ASCOM diagnostics and if I choose "QHYCCD camera capture2 " the menue comes up, then it worked once in NiNa. but after I closed ascom diagnostics and ran again NiNa , the error come up

Carles

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #3 on: February 01, 2021, 07:16:12 PM »
    Well,I need test it,please wait some time.
Best Regards,
QinXiaoXu

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #4 on: February 01, 2021, 10:34:38 PM »
Hi,
    I tested QHY8L with the ASCOM plug-in driver and NINA,I can connect and capture images and tested two times has no issue.
Best Regards,
QinXiaoXu

Sniuk

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #5 on: February 02, 2021, 07:59:57 AM »
Hi,
    I tested QHY8L with the ASCOM plug-in driver and NINA,I can connect and capture images and tested two times has no issue.
Best Regards,
QinXiaoXu

Hi,

what version of NiNa did you use? and what driver was it? Also what SO did you test on?
I use Nina 1.10 HF2 Beta011, windows 7, 64bit  , ASCOM platform last version, and the qhy8l ascom drivers I've mentioned.

I've tested many times, and in ASCOM Diagnostic, choosing "QHYCCD camera-capture" I get that dialog, but right after, withouth even touching the usb, I try NiNa and it doesnt find any camera.  Even if I close ASCOM diagnostics and disconnect usb, to start from fresh in NiNa, it doesn't work.  That's why I'm asking what version of NiNa...perhaps the problem is on that side..
regards

Carles
« Last Edit: February 02, 2021, 08:04:48 AM by Sniuk »

Sniuk

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #6 on: February 02, 2021, 03:15:12 PM »
ok,

i've updated with yesterday's ASCOM All-in-one installer from yesterday 210201.10, and also Nina to version 1.10. HF02, 0.12beta. and it works, using it right now :)

Thanks!

Carles.

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #7 on: February 02, 2021, 07:12:52 PM »
    OK,if you have other issue,please let me know.
Best Regards,
QinXiaoXu

Sniuk

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #8 on: February 05, 2021, 04:33:16 AM »
    OK,if you have other issue,please let me know.
Best Regards,
QinXiaoXu

Thank you,
 actually...I have another issue.
 even though I set the Gain and Offset in that ASCOM driver,
when I open a file in Nebulosity and check the info, it states offset 0 . how is that possible?

One more question...
Now that I am able to use Slow speed download for the QHy8l, should I re-do the DARKS, FLATs and DARK-flats? too?
Or the change in speed doesn't affect those?  Since been told when high speed download resolution/sensitivity drops.. I wonder if I should redo my calibration frames for the new settings.

Thanks!

Carles
« Last Edit: February 05, 2021, 06:04:58 AM by Sniuk »

ma_rs

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #9 on: February 07, 2021, 02:22:33 AM »
About the Nebulosity problem: the ascom connection do have some problem about setting change, sometime you have to  reconnect the camera to make new settings work.
I try to use QHY Universal in Nebulosity, the image info looks ok. You need to replace the "qhyccd.dll" first
You can download "qhyccd.dll" here https://www.qhyccd.com/file/repository/publish/SDK/210201/sdk_WinMix_21.02.01.zip

ma_rs

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #10 on: February 07, 2021, 02:30:26 AM »
About the other question: You should redo the calibration frames for the new settings.

llsong

  • *****
  • 152
    • View Profile
    • Email
Re: Qh8L 64Bit ASCOM drivers not working
« Reply #11 on: February 07, 2021, 02:57:53 AM »
Hello  When the high-speed or low-speed mode is changed, the corresponding calibration frame needs to be re-shot

Sniuk

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #12 on: February 07, 2021, 03:23:55 AM »
About the Nebulosity problem: the ascom connection do have some problem about setting change, sometime you have to  reconnect the camera to make new settings work.
I try to use QHY Universal in Nebulosity, the image info looks ok. You need to replace the "qhyccd.dll" first
You can download "qhyccd.dll" here https://www.qhyccd.com/file/repository/publish/SDK/210201/sdk_WinMix_21.02.01.zip

Thank you for your answers
I have updated the qhyccd.dll file and still not showing offset usign ASCOM but it does show in the native driver.

Also noticed that when debayer and before color balance, since I am using Optolong L-pro I usually have blue hue , but since I switched to ASCOM is very RED . how come?

And one more thing, in NiNa when I use ASCOM it detects the bayer matrix automatically to RGGB and the qhy8l always had GBRG..

 I attach a file. Left is previously with Native driver, and right is last night with ASCOM driver. is a single sub and debayered with same settings in Nebulosity... it happens the same when I stack it in DSS and open in STarTools. Very RED... does the driver perfom any kind of balance? it shouldn' be red as far as I know.
« Last Edit: February 07, 2021, 04:22:41 AM by Sniuk »

Sniuk

Re: Qh8L 64Bit ASCOM drivers not working
« Reply #13 on: February 07, 2021, 04:19:22 AM »
one more thing,
I have set up NiNa to write the offset in the file name.
when I capture with native driver the offset is shown, but when I capture with ASCOM driver it doesn't show.