QHYCCD

QHY183C cooler no longer works

QHY183C cooler no longer works
« on: January 24, 2021, 08:34:50 PM »
Hi,

So I went to take some darks after imaging the night before, but unfortunately the fan didn't spin up. Instead, I heard a low buzzing sound from the camera. I could see in Seqence Generator Pro that the camera was drawing 100%, but nothing happened. The camera still works, so I assume it's the peltier cooling part that has died (The camera has the familiar "fried electronic" smell)?

Is this fixable, and how much would it cost to fix? I bought it used for a very good price, so I don't want to spend a fortune on it ;)

I live in the UK

Thanks!

Yuki

  • *****
  • 403
    • View Profile
Re: QHY183C cooler no longer works
« Reply #1 on: January 25, 2021, 07:27:02 PM »
It looks like the diode is damaged.

If you have electric iron, you can fix it by yourself.

If not, you can contact Jan, he will repair the camera for you.

His email is: astrosoft@email.cz

Best Regards


Re: QHY183C cooler no longer works
« Reply #2 on: January 29, 2021, 07:32:41 PM »

Re: QHY183C cooler no longer works
« Reply #3 on: January 30, 2021, 05:18:15 PM »
Most likely he is talking about one of these, diode D1, this one is on a 163M, make sure yours is the same part number.

https://www.amazon.co.uk/Smbj12A-Marked-Diode-Surface-Mount/dp/B00LX6YUUG/ref=sr_1_1?dchild=1&keywords=SMBJ12A+diode&qid=1612048327&sr=8-1

See also this thread in here for a photo in the fourth msg.: The diode marked D1

https://www.qhyccd.com/bbs/index.php?topic=8464.0

Sounds like yours may be "open", if it was shorted it would trip the power supply.
Avoid plugging in DC components "hot", connect DC connections first then plug in the AC power cord of the power supply to avoid arcing and surges.



Re: QHY183C cooler no longer works
« Reply #4 on: January 30, 2021, 06:30:30 PM »
Right! I just checked, and there is nothing like that in my D1 position. It's missing! I take it it has got blown off then?!

Right, I don't know what has happened here. But if this black bit is the diode, then there must have been some serious amount of heat going on here. It has resoldered itself underneath the capacitor!!!

« Last Edit: January 30, 2021, 06:43:04 PM by gingerfish »

Re: QHY183C cooler no longer works
« Reply #5 on: January 31, 2021, 11:56:02 AM »
I can't see anything on the diode, other than the numbers 1628 (I think. It's really small!)

Yuki, can you confirm that I need a Smbj12A for the 183c? If not, what do I need to get?

Re: QHY183C cooler no longer works
« Reply #6 on: January 31, 2021, 05:32:29 PM »
Right! I just checked, and there is nothing like that in my D1 position. It's missing! I take it it has got blown off then?!

Right, I don't know what has happened here. But if this black bit is the diode, then there must have been some serious amount of heat going on here. It has resoldered itself underneath the capacitor!!!

That looks like the diode we are discussing, hard to believe it has dislocated so far away from the pads.  Are you the original buyer of this unit?  That's a real mess in there.

Re: QHY183C cooler no longer works
« Reply #7 on: January 31, 2021, 06:46:40 PM »
I think I know what has happened now. I asked the wife to plug it in for me as I was on the phone, and I think she might have plugged in the laptop charger instead of the correct cable... My own fault for having so many cables around!

Man, this thing was welded on there!!! It took me an hour to get it off!

Hopefully QHY will let me know what part I need :D

Yuki

  • *****
  • 403
    • View Profile
Re: QHY183C cooler no longer works
« Reply #8 on: January 31, 2021, 07:19:31 PM »
Hi,

Yes, you need a SMBJ12.

Pay attention to the direction of the diode when welding.

Best Regards


Re: QHY183C cooler no longer works
« Reply #9 on: February 01, 2021, 08:01:44 AM »
Excellent!

Re: QHY183C cooler no longer works
« Reply #10 on: February 05, 2021, 11:59:31 AM »
Board got cleaned up, and the new part was soldered on. Camera now works again! Thanks all!