QHYCCD

Ascom driver fails to read QHY5III290M - Reading CCD message

brew

I am experiencing another problem with my QHY5III290M when used as a guider in MaximDL. Many times, when I first take a guide exposure (3 sec) after connecting the camera in Maxim,

- the exposure is made
- Maxim tries to read the exposure. The screen says "Reading CCD".
- the read never completes. The message stays for 1 minute after which Maxim times out and displays an error message
   ImageArray error while transferring image
   Could not invoke "ImageArray"
   Reason: Exception occurred.
   ASCOM.QHYCCD_GUIDER.Camera:
   Call to ImageArray before the first image has been taken.

Normally the Reading CCD message is very fast; often I don't even see it because it goes by so fast.

The worst part of the problem is that I can't reliably clear the camera to begin operating again. I have tried the following, with no success; the camera continues to hang on Reading CCD.

1) Stop exposure in Maxim, disconnect cameras, reconnect.
2) Stop exposure in Maxim, close Maxim, restart Maxim, reconnect.
3) Stop exposure in Maxim, disconnect cameras, select different guide camera, connect to cameras, disconnect cameras, select QHY guider again, connect cameras.
4) Stop exposure in Maxim, Unplug the USB cable to the camera (power off), wait 15 seconds, replug the USB, reconnect the camera.
5) Stop exposure in Maxim, exit Maxim, Unplug USB, wait 15 seconds, plug in USB, restart Maxim, connect camera.
6) Stop exposure in Maxim, Exit Maxim, shut down all programs, Reboot the entire computer, start Maxim, connect the camera.

The 6th technique sometimes clears the system and the camera will begin working again. However, this is not reliable; it may take several reboots before the camera begins to work.

The situation seems to occur when the camera has been idle awhile, perhaps an hour or more. Once the camera starts working it will run through the night. If I leave the system running (but idle) through the next day, the camera will likely hang and I have to start rebooting the system over and over.

Unplugging the USB is not very feasible, since the system is located remotely. I have to drive to the observatory and unplug the cable.

For the same reason, rebooting the system is risky. If the reboot doesn't complete for some reason I have to drive to the observatory to reboot.

I don't know how to begin debugging this. I did try one thing: I turned off the Windows capability to power down the USB port, under the theory that Windows was powering off the port and the driver couldn't handle that. However, that did not cure the problem.

System info: Windows 10 64 bit i5-4660 2 core, 12 Gb, updated to 1909.
Maxim: version 6.20
QHY driver:     SDK 20.5.23.3
   includes fix for not waiting for guide move to complete.
QHY Ascom driver 0.1.51.44

This does not occur for ST-i, ASI120, STF8300, QSI683, or ST2000 cameras. Only the QHY encounters this problem.

I have uninstalled and reinstalled the drivers, including copying the patched qhyccd.dll to the Ascom folders. This did not fix anything.

It seems the issue is with the SDK file qhyccd.dll? How can I tell if it is messed up or needs some sort of reset?

Re: Ascom driver fails to read QHY5III290M - Reading CCD message
« Reply #1 on: June 21, 2020, 08:23:32 PM »
Hi,
    After camera hung some time,capture will occur issue?Well,I know a similarly issue with this,I will check previous record and test it,please wait some time.
Best Regards,
QinXiaoXu

Re: Ascom driver fails to read QHY5III290M - Reading CCD message
« Reply #2 on: June 30, 2020, 06:27:39 PM »
I use MaximDL also and a QHY5LII as a guide camera.  I was having the same problem until I setup camera 2 differently.  I use ASCOM as the camera model, and under the advanced tab> ASCOM Camera Chooser, I chose "CMOS QHY5LII Camera".  It has worked great ever since. 
Hope this helps.
Andy

Re: Ascom driver fails to read QHY5III290M - Reading CCD message
« Reply #3 on: June 30, 2020, 11:29:58 PM »
Hi,
    Thanks for Andy's advice.
    And you also can try use new version SDK.On my side,after connect camera in MDL,make camera in idle some time,after that capture test result also is good.You can download SDK from here:https://www.qhyccd.com/html/prepub/log_en.html#!log_en.md
Best Regards,
QinXiaoXu