QHY10 USB port not recognised

QHY10 USB port not recognised
« on: December 04, 2017, 10:48:28 PM »
I have been trying to get my QHY10 working again
Drivers system and ASCOM drivers downloaded and installed (on windows 10 64 )
Latest version of ASCOM

When plugged in I get the USB not recognised windows warning. (tried all 4 USB ports)
Occasionally I get one of the two drivers QHY10 base Driver or QHY 10 IO  Driver but never both .
With the Io driver Sequence generator Pro can connect but will not download a picture. It then crashes out and re connection goes back to USB recognised.
DO both drivers have to be working to use ASCOM connection.
I have tried 3 different computers all with the same result.
Is the camera faulty  ?
Thanks for any help

Re: QHY10 USB port not recognised
« Reply #1 on: December 18, 2017, 12:06:55 PM »
I had a similar problem with my QHY10 and it was solved after conecting to USB 3.0.


  • *****
  • 5000
    • View Profile
    • Email
Re: QHY10 USB port not recognised
« Reply #2 on: December 20, 2017, 10:59:48 AM »
Maybe need to check USB cable. Sometimes if USB cable has some problem it may cause this also.

Best regards,
QIu Hongyun
Qiu Hongyun