QHYCCD

QHY11 problem with Temperature Auto Control

QHY11 problem with Temperature Auto Control
« on: March 12, 2013, 02:48:31 PM »
Hi,
It's my first experience with camera under control of absolute value of sensor's temperature.
It looks like I have problem with Thermoelectric coller operation.

It work very well in manual regime.
Auto control also works pretty well in passive mode (without image capturing).

Problem arises when I try to use Auto Control during imaging.
Auto control stops to work well after 10-20 sec of the begining of image capturing.
Temperature control window show picture with freezed (does not change with time) value of sensor temperature.
So, if initial temperature was, for example, above Control value, thermo cooler try to increase power instantly.
It leads to droping of the temperature far below control value  and vice verca.
After finishing of the exposition the temperature value in temperature control window bacames "alive" and starts indicate real temperature of the sensor.
Auto control starts to work again well and correct sensor's temperature.

I try explain that in attached picture.(see attached)
Camera worked for image capturing in Temperature Auto Control mode during time 1.
The Control value of Temperature was -10C. But Auto Control did not work and I had temperature rise up to T1.
After finishing of image capturing (during time 2), auto control started and try to decrease temperature to Control value T2.

I used:
EZCAP 3.13
QHY11 driver QHY11Drv64V13-02-20
Windows 7/32

Maxim
 
« Last Edit: March 12, 2013, 03:03:17 PM by 73km »

QiuHY

  • *****
  • 5005
    • View Profile
    • Email
Re: QHY11 problem with Temperature Auto Control
« Reply #1 on: March 12, 2013, 09:41:20 PM »
Hello,

      During the image data readout normally we stop the temperature control function to avoid it effect the readout timing of the CCD sensor. So you will see a 10-20sec pause. But the temperature should not change a lot since it will just hold on but not return to enviroment temperature.  So the curve you show has some problem that it increase fastly during this period.

      We need to do a compare test here. 


Best regards,
Qiu Hongyun

Re: QHY11 problem with Temperature Auto Control
« Reply #2 on: March 13, 2013, 04:09:07 AM »
Thank you for fast reply.

Probably, here misunderstanding.

I am saying not about readout time but time of exposure.
Temperature auto control function does not work during exposure time.
(At least I observed that sensor temperature is constant and automatic power changing does not effect upon temperature)
In my previous message (see picture) period 1 corresponds to exposition time =900s.
At such long exposure time I observe high difference between Control value of temperature and temperature in the beginning of period 2 (which should coincide with temperature at end of exposure).

Hope, my problem description now is clear.
Maxim
 

lzr

Re: QHY11 problem with Temperature Auto Control
« Reply #3 on: March 15, 2013, 01:29:17 AM »
Hello

I am sorry.It is our mistake.

I fixed qhy11 problem with temperature auto control.

You can go to qhyccd.com to install the lastest driver to fix this problem.

http://qhyccd.com/file/repository/Driver/QHY11Drv64V13-03-15.zip

lzr

Re: QHY11 problem with Temperature Auto Control
« Reply #4 on: March 15, 2013, 01:31:01 AM »
By the way,you must uninstall the old driver before you install the lastest driver

Re: QHY11 problem with Temperature Auto Control
« Reply #5 on: March 15, 2013, 05:30:16 AM »
Lzr,
Thank you.
We'll test it with new driver.
Maxim