QHYCCD

QHYCCD Software Developer Zone => QHYCCD SDK for MACOS => Topic started by: jcridings on February 02, 2021, 12:18:30 PM

Title: QHY 5-II and TheSkyX doesn't work
Post by: jcridings on February 02, 2021, 12:18:30 PM
I purchased a QHY 5-II monochrome guide camera several months ago to use with TheSkyX on MACOS and I have been unable to get it to work. I have managed to go from crashing TSX any time I tried to connect it to actually being able to take a frame and take continuous frames. It is not functional enough to use, though. I can take full frames, but it will not return a subframe. Instead, I get the spinning beachball of death and will have to force quit TSX. I've done this multiple times. Is there an X2 plugin that works and where can I get it?
MACOS 10.15.6 (Catalina)
TheSkyX 10.5.0 (Build 12846)
QHY hardware and driver information from TheSkyX auto guider camera GUI
Device name: QHY5PII-M-50c7e710f33c7357
Device description: QHYCCD camera
Driver information: V20200724_2
Driver version: 20.063
Firmware version: 15-4-23

Thanks.
-Jeff
Title: Re: QHY 5-II and TheSkyX doesn't work
Post by: ma_rs on February 04, 2021, 12:50:29 AM
Please try https://www.qhyccd.com/html/prepub/log_en.html#!log_en.md?#TheSkyX_plugin_Update
and let me know the result
Title: Re: QHY 5-II and TheSkyX doesn't work
Post by: jcridings on February 04, 2021, 08:52:22 PM
The short answer is it's very unstable. I went through the process of download and installation step by step as provided on the website you posted for the update. That worked very well. I had high hopes starting off because I was able to connect the camera without any issue and then take single and continuous frames. The only issue I had was the first frame took a while to download to the computer. Things went wrong when I tested binning and subframe. It would not take a subframe and TSX threw an error 206. I then tried 2x2 binning and that worked, but again took a long time to download the first frame. Somehow, I managed to get it to take a subframe and I was able to take single and continuous frames. When I tried to go back to full frame, it again would not download at all and TSX eventually threw an error. I tried going back to subframe and that would not work. I eventually got a full frame after shutting down everything and starting over, but was never able to get a subframe again. I went through this process multiple times and every time eventually got to where I could not get any frame to come back. Subframes are essential for the guide calibration to work (the way TSX does it).
The only information that changed is
Driver information: V20210201_10
All the other hardware and driver information in the imaging system setup GUI did not change.
-Jeff

I went back and reviewed everything, and the command line code has a comment that says it should be _20 whereas I seem to have gotten _10. I'm not sure that it installed properly. I also noticed there's an install.sh in the plugins_macMix directory but there's no command line to execute that like for the sdk, just the copies.
Title: Re: QHY 5-II and TheSkyX doesn't work
Post by: ma_rs on February 07, 2021, 01:39:48 AM
I try some cameras on Windows Mac and Linux(Ubuntu 16), 5PII is kind of unstable when you switch frame size a lot(bin SubFrame, etc)
basically, it's a stream traffic problem, I will report to the developer, add to the bug list and hopefully fix it soon.
Title: Re: QHY 5-II and TheSkyX doesn't work
Post by: jcridings on March 28, 2021, 09:04:36 PM
Is there any update on this? I downloaded 21.03.13 and there is no difference.
Thanks.
-Jeff